
SDHelper7 Users Guide 
 

SDHelper is a simple program designed to assist the caller in using all the calls on a 

particular list, as well as to stimulate the creative juices by "suggesting" which calls could 

be used next.  The program allows you to read a list of calls into a list box.  About 9 calls 

are displayed in the list box (New Calls), however the user may scroll down to find more 

calls, or drag on the bottom of the window to make the lists longer.  Calls which are used 

are moved into another list box (Used Calls).  Calls may be sorted in alphabetical order 

(Sort List), or shuffled into random order (Shuffle List).   

 

Installing the program 

 

Create a folder named sdhelper.   Copy the default call list files and the SDhelper7.jar 

and/ or the SDhelper7S.jar file into the folder.  Open the folder and you should see 

something like this: 

 

 
 

Here we show the default list names (e.g., c1.txt contains the entire C1 list including 

concepts, c1c.txt has only the C1 concepts, c3.txt and c3c.txt contain the combined C3B 

and C3A calls and concept lists respectively) and the two versions of the program.  You 

can also create your own lists as simple text files.  

 

 

SDHelper is written in JAVA and should work on any machine which has the Java 

Runtime Environment installed.  If you do not have the JRE on your computer, download 

JAVA for free from https://www.oracle.com/java/technologies/downloads/  and install it. 

To install the program, drag the sdhelper folder to whatever directory you want (or the 

desktop, it doesn't matter) and you are done.  There is no registration with your operating 

system.  The only requirement is that the executable jar file is in the same folder as the 

default call list data files.  This will work best if you put it on the C: drive.  You can then 

create a shortcut and put it anywhere you want. 

 

 

Double click on the SDHelper7 jar file icon, and you should see:  

https://www.oracle.com/java/technologies/downloads/


 

 
 

Or if you want a version where you can scroll through the tabs instead of showing them 

all at once use SDHelper7S which has a slightly smaller footprint: 

 

 
 

Both are showing the C4 tab as selected. 

 

 



Using the Program 

 

 

At the top of the window are a bunch of tabs.  These provide places to provide the caller 

with lists of calls (e.g., C4) or concepts (C4C).  Each tab will provide the corresponding 

call or concept list when File>Open Default is chosen.  You can have lists in each tabbed 

pane, however only the selected tab list will show at a time.  Click on any tab and 

Choosing File>Open Default will populate the New Calls list with the calls on the chosen 

list. 

 

Choosing File>Open Default at C4 produces: 

 

 
 

 

 

The "New Calls" list is populated with the list of C4 calls which I use or teach in the 

order I typed them (looks like 455 of them).  Click in the list box and then press the 

"Shuffle List" button and the New Calls list will be randomly shuffled.  Click on "Sort 

List" and the New Calls list will be sorted alphabetically.  Calls are selected either by 

clicking on the call and then pressing "Pick Call", or double clicking on the call.  The call 

is then deleted from the "New Calls" list and placed in the "Used Calls" list.  After 

selecting the call you can use it in your sequence.  

 

The window below shows how things look after shuffling and using several calls. 



 
  
 

If you wish you can clear the "Used Calls List".  Starting each sequence with a blank 

"Used Calls" list enables you to see how many calls at the level you have used in that 

sequence.  It also enables you to save only the "New Calls" list.  I started out by clearing 

the list a lot, now I don't.  Chose Actions>Delete and a popup will ask which list you 

want to delete: 

 

 
 

. 

 



This will popup if the New Calls list is active 

 

 

 
 

This will popup if the Used Calls list is active followed by the above popup. 

 

 
 

  

You can also change the relative sizes of the boxes by dragging the divider between the 

two boxes: 

 

 
 

 



You can also resize the window by dragging the edges or corners: 

 

 
 

 
 

 

 

There are a variety of ways to use the program.  One can populate several tabbed panes 

and move from one level to another and pick calls and/or concepts.  Or you can read 

several call lists into the "New Calls" list.  For example, I might want to write a C-3 

dance where the ratios of C3B – C3A – C2 – C1 are 3:2:1:1, i.e., for every 3 C3B calls I 

use I also use 2 C3A calls, 1 C2 call and 1 C1 call (on average).    So I select the C3B tab 

and load 3 copies of the C3B list using File>Open Default three times (the default file 

loads automatically, without using a file chooser), then use File>Open Dance to select the 

default C3A list (c3a.txt) and choose “2” from the drop down menu on the right: 

 



 
 
The drop down menu on the right controls how many copies of the list are added to the 

New Calls list.  The default number is one. 

 

 

 

 
    

Choosing no will overwrite the current list (plus generate the following bug, which I may 

fix); 

 

 
 

 

 



If you are teaching a class, you can use File>Open Class.   

First create a text file with the list of calls in the order you wish to teach them (one call 

per line, followed by <enter>)..  Save the file in the sdhelper folder. After choosing the 

class list (and the number of copies desired) you see the popup: 

 

 
 

Choose yes and you see: 

 

 

 
 

The number corresponds to the number of calls on the list you wish to use.  E.g. if at the 

end of the night you will have taught all calls up to call number 30, enter 30. 

 

 

 

Saving Call Lists 
 

When you are done for the moment, you can save both the "New Calls" list and the "Used 

Call" list.  File>Save As will open up a File Save dialog which will enable you to save 

the "New Calls" list by whatever name you wish.  If the "Used Calls" list is not empty, it 

will also be saved with the same name plus ".used".  If you don't want to save the "Used 

Calls" list, then "Clear Used List" first.  If you just want to save the "Used Calls" list - 

tough.  If you have several panes in use you will have to save them individually.  Once 

you have saved the file, choosing File>Save will save the file with no accompanying 

dialog. 

 

 



 
 

The Menus 

 

 

 
 

 

 

The File menu allows you to save and open files.  The Save option may not work unless 

you have previously used Save As.  Close ends the program without saving the lists. 



 
 

 

The Edit Menu allows you to add a call to the New Calls List, delete all instances of the 

named call from both lists, fix the spelling of all instances of the named call from  list, 

and duplicate the selected call.  So if you want to add the call “Fred” 6 times , View>Add 

Call Fred and then Duplicate Call 5 times. 

 

 
 

The View Menu allows you to change the font size in the list boxes, and to choose a more 

limited selection of level tabs, e.g., after View> Pick Call Levels> C3A-C4 you will no 

longer see tabs for levels lower than C-3A: 



 
 

 
  

This is quite helpful if using the other version, it can reduce the size of the window.  Here 

is the starting window: 



 
 
And here is the window after choosing View> Pick Call Levels> C3A-C4 and View> 

Pick Concept Levels> C3A-C4. 

 

 
 

 

 



You can also click on the  “x” on each tab to remove it. I generally use only one or two 

tabs which makes the window a bit smaller.  Alternatively you can remove or add tabs 

using the Call Levels or Concept Levels Menus: 

 

 
 

Here I have just used the C4 and C4C tabs, for now you can’t get rid of the Sight tab.: 

 

 



The Actions menu gives you the choice of deleting the New Calls and/or Used Calls list, 

or to “Reload”.  Reload clears the Used Calls list and appends it to the New Calls List: 

 

 
 

 

Neat Things the Program Does 
 

If you click in a list box and type the first few letters of a call, it will scroll down to the 

first occurrence of those letters.  This helps if you use a call not currently offered and 

want to put it in the used list. 

 

If you suffer from transitory memory loss, you can alphabetize and scroll thru the list 

until you find that darn call that has the centers do this and the ends do that. 

 

If you don't like the calls offered, you can shuffle the list and get some new ones. 

 

If the New Calls list is nearly empty but the only calls that are left are yucky (but you 

really need to use them 'cuz you're teaching a class and they need the exposure) just 

append your original list (maybe delete the Used Call list first) and you will see more of 

the yucky calls than the other calls and you can force yourself to use them. 

 

If you accidently picked a call you didn't use, click on the call in the "Used List", push 

"Pick Call"(or double click on the call), and it will go back where it belongs. 

 

Once you have gone through the list all the way or as much as you want to, press 

“Reload” and the used calls are transferred back to the “New Calls” list. 

 



Tips for Using the Program 

 

I generally use only one tab; rarely, I bring up another tab or two to use a reference.  You 

can use multiple tabs as an alternative to creating dance-specific lists. 

 

I like to create individual lists tailored to specific dances or dance groups.  So I may have 

a list for group A (easier C3) which uses a ratio of 4:3:3 C3B:C3A:C2, and another list 

for group B (harder C3) using a ratio of 1:1 C3B:C3A. 

 

When you have written enough material for the dance, you can save the lists and later 

restart where you left off.  This way calls not used at the first dance may be used at the 

second.  This is useful if calling for a regular club.  If you don’t want to do this make sure 

the list was saved when you created it, or save it using Actions >Reload followed by 

File> Save As. 

 

Be careful if you tend to use a lot of calls not suggested by the program.  For example if 

you can see that “Flip back” will get you to a Right and Left Grand, but is not one of the 

call choices, use the call, but consider finding “Flip back” in the New Calls list and 

putting it in the Used Call list.  This tends to even out the frequency of call use. 

 

Some calls have many variations, e.g., the call “Cross and Wheel” has the following 

variations: 

 

Cross and Wheel 

Cross Trade and Wheel 

Grand Cross Trade and Wheel 

Single Cross and Wheel 

Single Cross Trade and Wheel 

Grand Single Cross and Wheel 

Grand Single Cross trade and Wheel 

 

If you consider each of these to be a unique call, your call list will be heavily biased 

toward the use of Cross and Wheel variants.  You may choose to use a call name like 

“Cross and Wheel Variations” in your list and decide on the fly which version to use, or 

my preference is to explicitly use each variation, but balance out the list by using all other 

calls 4 times.  So my list might have the above Cross and Wheel variations plus 3 or 4 of 

all the other calls on the list, e.g.,  

 

Percolate (3 times) 

<anything> Percolate (once) 

Grand Chain 8 (lines) 

Grand Chain 8 (8 Ch) 

Grand Chain 8 (DPT) 

1/3 recycle  

2/3 recycle (3 times) 

Split recycle (3 times) 



Sight Calling 
 

You can use the program when you sight call.  Select the “Sight” tab: 

 

 
 

 

You can select the number of lines you wish to display, choose from several font sizes 

and also choose which mouse buttons will be used.  Here is what you see after choosing 2 

lines at 50 point font using left and right mouse buttons and the C4 list.  Note that I had to 

drag on the right side to make the window wider, I also made it shorter. 

 

 
 



Now if I left-click anywhere in the middle part of the window, the first call will be 

chosen (deleted) and the second call will move up to the first call’s spot.  If I right-click, 

the program will reshuffle the calls and two new calls will be shown.  If I double right 

click the used calls will be reloaded back into the new calls list. 

 

If I select a single mouse button to use (Right Only, Left Only or Middle) then a single 

click chooses (deletes) the first call, a double click reshuffles the calls and a triple click 

reloads the used calls.  

 

You can also use the buttons, but I have altered my Hilton Microphone Cable to act as 

two-button mouse so I don’t need to touch my computer while I am calling. 

 

Turning your Microphone Cable Into a Mouse (old info)  
 

Now that we are using computers instead of turntables, the Hilton “Record Reset” button 

isn’t used.  It can easily be turned into a one-button mouse by taking the guts out of a 

standard USB mouse and wiring the switches to the appropriate plug.  This can be as 

kludgy as desoldering the mouse button switch and resoldering wires to the appropriate 

plug on the mouse, or pulling out just the parts you need and putting them in a small case.  

 

I chose to create a two-button mouse.  I bought a Gear Head Lighted Optical Mouse from 

FRY’S ($3.99), unsoldered the main chip, three resistors and one capacitor, cut off the 

cord, and resoldered them and put them in a small medicine bottle the size of a 35mm 

film can ( I have since bought 20 chips and can make the mouse for about $20) .  I ran the 

appropriate three wires to a female 1/8 stereo phone jack on one end of the bottle, the 

USB wires I threaded through a drilled hole in the other end. 

 

The trickiest part is the modification to the Microphone Cable.  Since I needed a 1/8 male 

stereo plug I had to cut off the Record Reset Phono Plug and put in the 1/8 stereo plug.  

This required running a wire up to the junction of the three mic wires and soldering I to 

the ground sheathing.  At the business end of the mic I did pretty much the same thing.  I 

started with a new white plastic thingy (no hole drilled for the reset switch) generously 

supplied to me by Hilton and cut a small rectangular hole (about 3/16 x 3/8 inches) for 

the double pole single throw momentary switch I was installing sticking (about $8 plus 

shipping from Mouser.com).  Then I soldered the middle terminal to a 2” wire, and 

soldered the other end to the ground sheathing.  I soldered the two Record Reset wires to 

the other terminals, reassembled and was set.  Total cost less than $20. 

 

If you want I can send detailed instructions on how to do this including pictures and parts 

list. 

 

 

 

 

 

 



Default File Names 
 

I have included default files for each tab.  The file names are: 

"c4.txt", "c3.txt", "c3b.txt", "c3a.txt", "c2.txt", "c1.txt", "a2.txt", "a1.txt", "plus.txt", 

"ms.txt", "c4c.txt", "c3c.txt", "c3bc.txt", "c3ac.txt", "c2c.txt", "c1c.txt" 

 

The C4 list is the list I stick somewhat close to (maybe), all other lists (except C3B) are 

the Callerlab lists arranged as I saw fit.  Feel free to change them to suit yourself, just 

don't change the name if you want it to remain the default list.  C3 contains both the 3A 

and 3B lists.  The second "c" denotes a concept list.  Any other lists you use may be kept 

wherever you like, my machines save them in the C:sdhelper folder by default. 

 

Please check each list to see that it is current and includes the calls the way you want 

them.  E.g., at C-1 I may have Vertical 1/4 tag, Vertical 1/2 tag, Vertical 3/4 tag, Vertical 

tag.  You may want only the entry “Vertical tag”. 

 

When you make your own list, save it as a .txt file with one call per line such as: 

 

1/4 Mix 

1/4 Wheel The Ocean 

1/4 Wheel The Sea 

1/4 the Deucey 

3/4 Mix 

3/4 The Deucey 

3/4 Wheel The Ocean 

3/4 Wheel The Sea 

<ATC> Chain Thru 

<ATC> Reaction 

<ATC> Cross Reaction 

<ATC> Your Leader 

<ATC> er's Delight 

 

 

Hidden Features 

 

 

Whenever you select a call from the new calls list, the call is saved to the clipboard.  I use 

X-Mouse Button Control (free from 

https://www.highrez.co.uk/downloads/xmousebuttoncontrol.htm ) to program my mouse 

so that after a call has been selected (by pushing Pick Call, or double clicking on the call) 

left clicking then right-clicking on the SD call input box pastes the call into SD, and then 

pressing the middle mouse button or scroll wheel enters the call into SD.  So I can 

actually write material using SD without touching the keyboard. 

 

In order to do this it is necessary for the calls to be in a form SD recognizes. E.g., 

“<anything> motivate” rather than “anything motivate”.   

https://www.highrez.co.uk/downloads/xmousebuttoncontrol.htm


Tracking call usage.  Select a call by clicking on it in either the New Calls list or the Used 

Call list.  Then right-click on the call and a pop up will tell how many times the call has 

been used and how many are still unused.  The popup will disappear automatically after 

two seconds: 

 

 
 

 

Suggestions For Improvement 
 

Are welcome, bearing in mind that this is intended to be a very simple program designed 

to take the place of the multiple piles of Index Cards I once shuffled up to help write 

dances. 

 

 

Add an option to delete files. 

 

Create a version which would suggest calls which would change from one formation to 

another e.g., you have waves and want columns, choose waves->columns and see stuff 

like split transfer, follow your leader, reset 1/2, etc. However SD helps with this, use 

Command> Create Setup. 

 

Put in a third column of concepts so you can see both calls and concepts at a level.  This 

would mean enlarging the window which may not be a good thing, however there would 

be room for more buttons.  For the most part I do not see a great need to "force" the use 

of concepts.  I do like to use calls with roughly equal frequency (except for the yucky 

ones, unless it is for a class or workshop). 

 

 

 

 

 

 

 

Other Stuff 
 

 

Feel free to give the program to anyone who wants it, please include this file. 

 

E-mail me at jknamwob@gmail.com if you have any questions/comments/suggestions or 

want to receive any updates. 

mailto:jknamwob@gmail.com


 

 

IMPORTANT 

 

Do not assume that you can just call the calls in the order they come up.  It won't work.  

The order is completely random.  Sometimes none of the displayed calls are useful; you 

can scroll down and find a call, or if you know what you want to call type in the first few 

letters, or press the Shuffle List button to get some new choices. 

 

Remember, the displayed calls are only suggestions; you are responsible for the final call 

choice.  Using this program may help you even out call frequency of use. 

 

 


